Opened 4 years ago

Closed 4 years ago

#12224 closed defect (wontfix)

wxPython: Unable to disable menu items on Mac OS X

Reported by: dan_koch Owned by:
Priority: normal Milestone:
Component: wxPython Version: 2.8.11
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

Hi folks,

Under certain conditions I disable some menu items under my app's Help menu using the wx.MenuItem.Enable(False) function. This works fine on Windows and Linux but not Mac OS X. Just to be sure, I have an event handler for wx.EVT_MENU_OPEN and it reports False for these items using the wx.MenuItem.IsEnabled() function. However these items are not dimmed under the Mac Help menu and when selected, they still operate.

Attachments (1)

mac_help.pyw download (916 bytes) - added by dan_koch 4 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 4 years ago by vadz

  • Status changed from new to infoneeded_new

We'd really need a way to reproduce this, ideally in C++ code. So if you could please make a patch to the minimal sample, it would be great. If not, please make at least an as small as possible example in Python.

comment:2 Changed 4 years ago by dan_koch

  • Status changed from infoneeded_new to new

I've uploaded a small Python example since I don't code in C++.

Changed 4 years ago by dan_koch

comment:3 Changed 4 years ago by dan_koch

I've tweaked my example to report status of the menu item when the menubar is opened.

comment:4 Changed 4 years ago by robind

  • Resolution set to wontfix
  • Status changed from new to closed

This is fixed already in 2.9. It's probably not worth the effort to track down the fix and backport to 2.8.

Note: See TracTickets for help on using tickets.