Opened 11 years ago

Closed 10 years ago

#12189 closed defect (fixed)

wxWidgets 2.9.1 crashes application upon startup

Reported by: Big Muscle Owned by:
Priority: normal Milestone:
Component: wxMSW Version: stable-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

I successfully compiled 2.9.1 (development version downloaded from WX homepage), but now when I run my application, it crash immediately upon startup (before any of my code is executed):

A buffer overrun has occurred in StrongDC.exe which has corrupted the program's internal state. Press Break to debug the program or Continue to terminate the program. 



For more details please see Help topic 'How to debug Buffer Overrun Issues'.

Callstack is:

>       StrongDC.exe!_crt_debugger_hook(int _Reserved=1)  Line 62      C 


        StrongDC.exe!__report_gsfailure()  Line 298 + 0x7 bytes        C 


        StrongDC.exe!wxClassInfo::Register()  Line 252 + 0x15 bytes    C++ 


        StrongDC.exe!wxClassInfo::wxClassInfo(const wchar_t * className=0x01d845dc, const wxClassInfo * baseInfo1=0x020c2310, const wxClassInfo * baseInfo2=0x00000000, int size=68, wxObject * (void)* ctor=0x01442c33)  Line 100     C++ 


        StrongDC.exe!`dynamic initializer for 'wxValidator::ms_classInfo''()  Line 29 + 0x20 bytes     C++ 


        StrongDC.exe!_initterm(void (void)* * pfbegin=0x01d74744, void (void)* * pfend=0x01d76c74)  Line 873   C 


        StrongDC.exe!_cinit(int initFloatingPrecision=1)  Line 288 + 0xf bytes C 


        StrongDC.exe!__tmainCRTStartup()  Line 262 + 0x7 bytes C 


        StrongDC.exe!WinMainCRTStartup()  Line 189     C

Version 2.8.x is without problems. I also tried compiling and running samples distributed with wxWidgets, but same problem appears.

Just some info:

  • I use Visual Studio 2010 Ultimate.
  • wxWidgets lib compiled as debug, unicode, static, non-shared.
  • application compiled with /MTd - is it normal that output wxmsw29ud.lib has 128 MB, but 2.8.x has 64 MB only?

Change History (4)

comment:1 follow-up: Changed 11 years ago by byte

  • Priority changed from normal to high
  • Version set to 2.9-svn

I have a same issue when I select any menu item in any application with non-unicode build of wxWidgets.

comment:2 in reply to: ↑ 1 Changed 11 years ago by vadz

  • Milestone 2.9.1 deleted
  • Priority changed from high to normal

Replying to byte:

I have a same issue when I select any menu item in any application with non-unicode build of wxWidgets.

It can't be the same issue as it doesn't happen on startup. Please open a different bug report with the appropriate information for the bug you're seeing, i.e. the stack trace and, ideally, a patch to the minimal or menu sample needed to reproduce it.

comment:3 in reply to: ↑ description Changed 11 years ago by vadz

  • Status changed from new to infoneeded_new

Replying to Big Muscle:

I successfully compiled 2.9.1 (development version downloaded from WX homepage), but now when I run my application, it crash immediately upon startup (before any of my code is executed):

Obvious question: does this happen with any wx samples (e.g. minimal) or your application only? If the latter, it must be due to some miscompilation problem.

comment:4 Changed 10 years ago by Big Muscle

  • Resolution set to fixed
  • Status changed from infoneeded_new to closed
Note: See TracTickets for help on using tickets.