Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11607 closed defect (fixed)

Black toolbar in MSW mdi since r62971

Reported by: troelsk Owned by: vadz
Priority: normal Milestone: 2.9.1
Component: wxMSW Version: stable-latest
Keywords: regression Cc:
Blocked By: Blocking:
Patch: no

Description

Apply patch and run samples/docview: toolbar background is black

Attachments (1)

toolbar-mdi.patch download (700 bytes) - added by troelsk 5 years ago.
Trunk

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by troelsk

Trunk

comment:1 Changed 5 years ago by vadz

I didn't test it yet but just a quick question: I assume this happens with MDI parent frame only?

Thanks!

comment:2 Changed 5 years ago by troelsk

Yes this problem is manifest with the MDI parent frame only AFAIK. The toolbar sample etc works fine here.

comment:3 Changed 5 years ago by vadz

  • Keywords regression added
  • Owner set to vadz
  • Patch unset
  • Status changed from new to accepted

Actually I don't even need any patches to see it, the problem is obvious in the unmodified mdi sample.

comment:4 Changed 5 years ago by VZ

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [63104]) Restore default WM_ERASEBKGND handling for wxMDIParentFrame.

We pretended that we erased the background ourselves but actually we did not.
Just let DefWindowProc() do whatever it does by default to fix the problem
with wrong toolbar background colour since r62971.

Also removed the unused and unneeded WM_SIZE handler as well.

Closes #11607.

comment:5 Changed 5 years ago by troelsk

Works well again now.
Thanks!

Note: See TracTickets for help on using tickets.