Opened 5 years ago

Closed 5 years ago

#11577 closed enhancement (fixed)

wxFileStream improvements

Reported by: steve_lamerton Owned by:
Priority: normal Milestone:
Component: base Version: stable-latest
Keywords: wxfilestream streams Cc:
Blocked By: Blocking:
Patch: yes

Description

Currently for a few wxFileStream functions you need to downcast to get rid of the ambiguity caused because it is inherited from wxFileInputStream and wxFileOutputStream. This patch implements the functions and also adds the missing documentation.

Attachments (1)

filestream.patch download (2.5 KB) - added by steve_lamerton 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by steve_lamerton

comment:1 Changed 5 years ago by vadz

  • Status changed from new to confirmed

Thanks, will apply this soon.

AFAICS the same thing needs to be done for wxFFileStream too so I did it as well.

comment:2 Changed 5 years ago by VZ

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [62995]) Override some methods in wxF(F)ileStream to resolve ambiguities.

Override virtual methods IsSeekable(), GetLength() and OnSysSeek/Tell() to
forward to wxF(F)InputStream base class as otherwise it's impossible to use
them at all because of ambiguity between the versions inherited from this
class and wxF(F)OutputStream (even though the two versions should do the same
thing as they operate on the same file descriptor/handle).

Also improve documentation of these classes: provide a brief description,
correct the base classes.

Closes #11577.

Note: See TracTickets for help on using tickets.