Opened 5 years ago

Closed 5 years ago

#11485 closed defect (invalid)

wxAlphaBlend breaks in wxScrolledWindow [MSW]

Reported by: nitram_cero Owned by:
Priority: lowest Milestone:
Component: wxMSW Version: stable-latest
Keywords: wxAlphaBlend scrolled window Cc:
Blocked By: Blocking:
Patch: no

Description

It happens at src/msw/dc.cpp @ line 2557.
File revision r61616

It only breaks when scrolled (tested scrolling down) because of a wxAlphaPixelData::Iterator "pSrc" having a bad pointer.

My bets are that it's probably has to do with "yDst" parameter being negative, and trying to write "before" good memory.

Best regards.

Change History (2)

comment:1 Changed 5 years ago by vadz

  • Status changed from new to infoneeded_new

How does it break exactly? How can the problem be reproduced (ideally with a patch to the sample)?

comment:2 Changed 5 years ago by nitram_cero

  • Priority changed from normal to lowest
  • Resolution set to invalid
  • Status changed from infoneeded_new to closed

Nevermind, it was my own mistake. I used a negative source point for the blitting.

I'm terribly sorry for the inconvenience.

Note: See TracTickets for help on using tickets.