Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11369 closed defect (invalid)

Broken menu items' bitmaps in Ubuntu 9.10 (Karmic)

Reported by: marfi Owned by:
Priority: normal Milestone:
Component: wxGTK Version: 2.8.10
Keywords: menu, items, bitmap Cc:
Blocked By: Blocking:
Patch: no

Description

Hi, it looks like menu items' bitmaps are completely broken in Ubuntu 9.10 (Karmic). Neither bitmaps set using wxMenuItem::SetBitmap() nor via standard menu IDs (for example wxID_EXIT) are displayed in menu items. The problem was observed in application built with GCC 4.4.1 with wxWidgets 2.8.10 and 2.9.1.

Change History (7)

comment:1 Changed 5 years ago by vadz

  • Priority changed from high to normal

Which GTK+ version is used in Karmic? Are there any GTK+ error messages or any other errors? Have you tried debugging this by chance?

comment:2 Changed 5 years ago by marfi

Version of libgtk2.0-dev library used in Karmic is 2.18.3-1. There is no additional error produced by application, and function wxBitmap::IsOk() returns TRUE.

comment:3 Changed 5 years ago by pcor

  • Status changed from new to infoneeded_new

Works for me with GTK+ 2.18.1. Ubuntu 9.10 is still beta. Run gtk-demo, double click Application main window, and open the file menu. Do you see images on the menu items?

comment:4 Changed 5 years ago by marfi

  • Status changed from infoneeded_new to new

I run the gtk-demo and there are no icons in the file menu so it looks like the problem is somewhere outside the wxWidgets.

comment:5 Changed 5 years ago by vadz

  • Resolution set to invalid
  • Status changed from new to closed

Then you're probably just using a theme which doesn't show bitmaps in the menus. In any case wx is supposed to behave in the same way as GTK+, which it does, IIUC, so I don't think there is any bug here.

comment:6 Changed 5 years ago by marfi

Here is a reply from Launchpad.net where I reported this "bug":

Thank you for your bug report. However, this is not a bug but a design
decision. /desktop/gnome/interface/menus_have_icons and
/desktop/gnome/interface/buttons_have_icons were turned off by default
in Karmic. You're free to turn them back on again if you prefer that

comment:7 Changed 5 years ago by VZ

(In [63609]) Document that images in buttons and menus might not be shown under GTK.

Mention gtk-{button,menu}-images GTK+ settings.

See #11369.

Note: See TracTickets for help on using tickets.