Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11310 closed defect (fixed)

When the Application Font size is changed, the menu bar height of wxGTK applications does not change accordingly.

Reported by: rainwoodman Owned by:
Priority: normal Milestone:
Component: wxGTK Version: 2.8.x
Keywords: Cc: dan@…
Blocked By: Blocking:
Patch: yes

Description

When the Application Font size is changed, the menu bar height of wxGTK
applications does not change accordingly.

Version-Release number of selected component (if applicable):
wxGTK-2.8.10-2.fc11.i586

How reproducible:

Always
Steps to Reproduce:

  1. Start any wxGTK application with a menu bar, eg, wxmaxima or VLC
  2. change the Application Font from the Appearance Preference dialog to a large

size (eg, from 9pt to 18 pt)

  1. Notice the menu texts in the menu bar in wxGTK applications are cropped, as

the height of the menu bar remains the same.

Actual results:
the menu texts in the menu bar in wxGTK applications are cropped, as the height
of the menu bar remains the same.

Expected results:
the height of the menu bar should be adjusted according to the height of the
font labels.

Additional info:
Restart the application will give good menu texts and good menu bar height.

(Forwarded from https://bugzilla.redhat.com/show_bug.cgi?id=528376) as requested.

Attachments (1)

wxpatch download (1.0 KB) - added by rainwoodman 8 years ago.
listening to size-allocate signal of GtkMenuBar and adjust menubar height, fixing the issue

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by rainwoodman

listening to size-allocate signal of GtkMenuBar and adjust menubar height, fixing the issue

comment:1 Changed 8 years ago by vadz

  • Status changed from new to infoneeded_new

Thanks for your patch, unfortunately it can't be applied to the trunk where wxFrame::UpdateMenuBarSize() doesn't exist any more. Maybe it's not needed there at all any more after the changes of r49406? Could you please test if the problems you encountered were fixed in 2.9.0?

Thanks!

comment:2 Changed 8 years ago by sharkcz

  • Cc dan@… added
  • Status changed from infoneeded_new to new

comment:3 Changed 8 years ago by sharkcz

  • Status changed from new to infoneeded_new

comment:4 Changed 8 years ago by PC

  • Resolution set to fixed
  • Status changed from infoneeded_new to closed

(In [62487]) update menubar size when style changes, fixes #11310

comment:5 Changed 8 years ago by rainwoodman

@vadz:

r49406 shall make the bug irrelavant, but I don't have the chance to test it.

@PC:
Your patch works. But could you show me the reasoning for why style-set is preferred than size-allocate?
I am just curious. Thanks.

Yu

Note: See TracTickets for help on using tickets.