Opened 6 years ago

Closed 22 months ago

#10205 closed defect (worksforme)

wxGrid clip the scrollbars out when created with wxDefaultSize argument

Reported by: mrgibson Owned by:
Priority: normal Milestone:
Component: wxMSW Version: stable-latest
Keywords: wxGrid wxDefaultSize Cc:
Blocked By: Blocking:
Patch: no

Description

If I create a wxGrid element using wxDefaultSize argument, the scrollbars are not drawn correctly. If I use a specific value like wxSize(200,200), this problem will not occur.

Tested with wxMSW, dont know about other OSes

Attachments (2)

sample_code.zip download (1.7 KB) - added by mrgibson 6 years ago.
Sample code, compiled using: g++ test.cpp app.cpp wx-config --libs --cxxflags -o test
minimal_grid.patch download (5.0 KB) - added by catalin 22 months ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by vadz

  • Status changed from new to infoneeded_new

Could you please provide the smallest patch to the minimal sample reproducing the problem (if it's really enough to just create wxGrid with default size it should be just one or two lines)?

TIA!

Changed 6 years ago by mrgibson

Sample code, compiled using: g++ test.cpp app.cpp wx-config --libs --cxxflags -o test

comment:2 Changed 6 years ago by mrgibson

  • Status changed from infoneeded_new to new

By the way, this bug also exists under wxGTK

comment:3 Changed 22 months ago by catalin

There's nothing wrong here.

Tested under wxMSW with the attached patch to the minimal sample which is build from the code in the OP's attachment. The linker needs wxXXX_adv lib.
Should probably be tested under wxGTK too to be sure but I doubt something will change.

Changed 22 months ago by catalin

comment:4 Changed 22 months ago by vadz

  • Resolution set to worksforme
  • Status changed from new to closed

Works for me under wxGTK too, thanks for the test case.

Note: See TracTickets for help on using tickets.